Jump to content

idmurp

Members
  • Content Count

    25
  • Joined

  • Last visited

About idmurp

  • Rank
    Member

Additional Information

  • Country
    United Kingdom

Contact Methods

  • Website URL
    http://
  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    Chester UK
  1. idmurp

    Western Arms cocking issues

    Still not got Internet back. But... Due to clearly bad design and nothing at all do to user incompetence I spotted the issue, I had the sear spring position wrong. Spotted it once I assembled with the safety removed. So that problem is solved. So now it cocks each time, and after a clean and lube feels very different to how it did before I started working on it. Can anyone tell me what part 71 is called, the spring in the blowback unit? When I fire it now the blowback unit is Jaming open and that spring is badly deformed and catching.
  2. idmurp

    Western Arms cocking issues

    My home internet is down tonight so can't check parts or try sort out my photo sharing. Will put photos up of all parts when it was is back. Reassembled without the safety, thank you that makes it much easier to see what's happening. Not to diagnose but I can at least see now how it works :p. It's really hard to video! Need 3 hands. Not that it will help as I can't see a difference in the movement of the disconnect or when it is successful or fails to cock. The trigger bar is not pushed back causing it to fail, the disconnector seems to move the same on a success or failure. I can manually cock 100% of the time Using the slide it works 90%, sometimes it goes through 6-7 cycles with no cock then starts again. Cycling the slide slower seems to help a bit. Probably not much help until I get photos up.
  3. idmurp

    Western Arms cocking issues

    My home internet is down tonight so can't check parts or try sort out my photo sharing. Will put photos up of all parts when it was is back. Reassembled without the safety, thank you that makes it much easier to see what's happening. Not to diagnose but I can at least see now how it works :p. It's really hard to video! Need 3 hands. Not that it will help as I can't see a difference in the movement of the disconnect or when it is successful or fails to cock. The trigger bar is not pushed back causing it to fail, the disconnector seems to move the same on a success or failure. I can manually cock 100% of the time Using the slide it works 90%, sometimes it goes through 6-7 cycles with no cock then starts again. Cycling the slide slower seems to help a bit. Probably not much help until I get photos up.
  4. idmurp

    Western Arms cocking issues

    About 6 years ago it started light striking and not cocking. I didnt strip it at the time and boxed it up intending to look at "later", its now later 😛 Bear in mind I am fairly practical but not worked on a gas blow back pistol before. I dont think the slide is worn, the disconnector is more worn but having seen a complete one now not that badly. Also see below for the change in performance now. The spring under the disconnector is there and seems to be working correctly. The disconnector is moving freely. I am assuming this spring is part 73 on this diagram http://www.pegatiros.com/download/despieces/westernarms/wa-Colt1911.jpg trigger bar seems to be working correctly Now I have removed the sear, inspected and put it back in and I'm getting it to work 90% of the time now, not 10%. No changes to it, just took it off, had a look and put it back. This is making me think its the sear? I am very tempted to bend the sear a tiny bit more, and see if that further improves matters, unless someone can suggest otherwise.
  5. idmurp

    Western Arms cocking issues

    SOrry trying again. Are these visible? Cant see any security settings. After removing the sear and refitting I have gone from successful cocks 1/10 attempts to 9/10. I did not make any changes, just removed, inspected and refitted. I cant see anything obvious wrong, is it possible the sear is just old? It still seams that I get more success if I depress the upper connector using my finger than with the slide. https://idmurp.imgur.com/all/
  6. idmurp

    Western Arms cocking issues

    Couldn't see anything obviously wrong. Stripped it right down and cleaned and reassembled . Everything feels a bit looser then I would expect but no obvious wear. Still performing the same. This did use to fire in this configuration, 10 years ago. Does the sear look right? It looks much "flatter" than the one on Dentrinity(thanks for that website btw) http://www.dentrinityshop.com/pr_list.jsp?cid=OTA_S&bid=SAR&pg=2&rpp=10 Preview attachment IMG_20181028_154345381.jpg Preview attachment IMG_20181028_154320751.jpg IMG_20181028_154320751.jpg 2.8 MB IMG_20181028_154345381.jpg 2.2 MB
  7. I have a WA infinity pistol Im trying to get shooting(its gonna be a bit of a project I suspect). the hammer wont cock when I rack the slide, if I push the indicated part down below the surface it will cock. The part looks worn. A.whats the part called, I know its part part 37 from the link below, anyone know where I can get replacements? B. Anyone know anything else likely to be the issue other than this? http://www.pegatiros.com/download/despieces/westernarms/wa-Colt1911.jpg cheers Ian
  8. idmurp

    Shotgun Picture Thread

    NP, I might to have a play at something like that. Simple and functional Ian
  9. idmurp

    Shotgun Picture Thread

    Heroshark whats the top one based on?(if anything) Any hints on how you did that? I like, simple and functional. Ian
×

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.