Jump to content
Gunfighters808

Initial Impressions of the TM SOPMOD M4 AEG

Recommended Posts

Just on a quickie for anyone that may have looked at this; is there an upgraded/replacement stock for the Sopmod? The gun feels so great and well built, right up until the cheap feeling stock. I even considered a front wire, but i'm sure I couldn't get a battery under that RIS (and I hate battery boxes!)

 

Eagle 6 sells Lipo's that go in the standard RIS

Share this post


Link to post
Share on other sites

With minor modification you can get a 800mAh 7.4 lipo inside a magpul stock if you like. Just make sure the wire coming out of the buffer tube is long enough. Mini deans recomended.

Share this post


Link to post
Share on other sites

I'm running into a weird issue while upgrading my SOCOM, after swapping to Prommy gears the gun will only cycle a few times then the trigger become unresponsive, and the battery wires get HOT. Right now I have the gearbox out with no piston or cylinder in it just to allow the gears to cycle with the grip mounted on.

 

Hi,

 

Obviously check shimming, but also some prommy sets the alignment between the top and bottom half of the sector gear is out, so you will have to file inbetween the teeth for smooth operation. yes its an actual prometheus product defect.

 

Im assuming they made lots of sets and its about 2 in 10 that have the issue, but personally i check every set now.

Share this post


Link to post
Share on other sites

Hi guys.

Any know solution to wobbling outer barrel ? That screw is just un gettin lose after few games.

 

Hi, You can send me the gun book it in via Info@eagle6.co.uk

 

Or if you dont want to send it to us then youll need a laylax tool and remove the whole front end and reassmble. Dont use anything other than blue loctite and even then its a risk. Regualr maintance is enough. And doesnt risk rounding off the head or us having to get the blowtorch out everytime a sopmod comes in thats been player "maintained".

Share this post


Link to post
Share on other sites

Hey guys, I recently acquired a mint condition sopmod and upon trying to affix my XTM panels/RVG grip I noticed they ALL wobble back and forth. Are the Sopmod rails slightly mis-sized or have I got a lemon RIS?

 

ta.

 

I used to run XTM covers when I had the oem rail and it was super tight. Though I also used the real steel versions, unsure if you're using pts and if its different

Share this post


Link to post
Share on other sites

 

 

Hi,

 

Obviously check shimming, but also some prommy sets the alignment between the top and bottom half of the sector gear is out, so you will have to file inbetween the teeth for smooth operation. yes its an actual prometheus product defect.

 

Im assuming they made lots of sets and its about 2 in 10 that have the issue, but personally i check every set now.

 

I was able to determine the issue, bevel was too far pushed out and binding against the motor pinion.

Share this post


Link to post
Share on other sites

Apologies for the FUBAR picture but it's difficult to take decent pictures at night :P

 

IMG_1368.jpg

 

TM M4 SOCOM

 

G&P URX flashhider

Madbul DD MK18 RIS II

Magpul PTS AFG2

Magpul PTS MOE stock

Magpul PTS trigger guard

TM PEQ-16

Laylax/FF CQB barrel

ARS ASAP

ACM T-1 red dot

 

Modify bushings

Systema hop up bucking

Eagle6 M100 spring

Eagle6 recoil spring

Prometheus 6.03 precision barrel

Prometheus gears

Prometheus cylinder head

Prometheus piston head

Prometheus nozzle

Prometheus selector plate

Prometheus spring guide

Lonex anti reversal latch

Magic Box piston

 

 

Got a Surefire M951 copy on it's way, not sure where or how to attach it :huh:

Share this post


Link to post
Share on other sites

I used to run XTM covers when I had the oem rail and it was super tight. Though I also used the real steel versions, unsure if you're using pts and if its different

 

I've tried genuine and knock off types.. they all seem to have about 1-2mm movement back and forth.. I'll probably be getting a new ris at some point but it's a little odd nonetheless...

Share this post


Link to post
Share on other sites

Hi, You can send me the gun book it in via Info@eagle6.co.uk

 

Or if you dont want to send it to us then youll need a laylax tool and remove the whole front end and reassmble. Dont use anything other than blue loctite and even then its a risk. Regualr maintance is enough. And doesnt risk rounding off the head or us having to get the blowtorch out everytime a sopmod comes in thats been player "maintained".

 

Richard Y I sent you a message about sending my gun to your for some work via the website the other day but I haven't heard anything back yet.

 

Thanks.

Edited by Banshee_Will

Share this post


Link to post
Share on other sites

On another note, anyone had experience trying to solve crane stock wobble (twisting)?

 

Get a stock tube wrench and tighten the lock ring. You can get hard lock rings that have a better thread so you can tighten them further.

Share this post


Link to post
Share on other sites

its not the stock tube but the stock itself, there is a lot of left-right movement. the hole in the stock that slides onto the stock tube is a good 3-5mm bigger and the only method I've found so far is using some electrical tape but then i lose the ability to quickly resize the stock..

Share this post


Link to post
Share on other sites

Yeah I don't know what Tokyo Marui did wrong with the crane stock, because the VLTOR stock had no wobble. When I switched over to the Crane stock, suddenly it was all wobbles.

 

--------------

 

On a different topic, anyone else have issues with their magazines? Even though my heat shrink mod to the bolt catch lever on the magazine helped a lot, it still from time to time would not engage. Also for the past two games I started having a lot of double feed issues that really screwed me over and caused me to lose out on a lot of kills.

 

Anyways I tore the gun apart and checked everything and it was fine, figured maybe the Prometheus air nozzle had something wrong with it so I put back in the stock nozzle, still double feeding. I thought maybe it was my bucking, so I took out the firefly bucking and put back in a standard style bucking, still double feeding. Anyways I read online a suggestion to spray silicon oil into the magazine, I felt this was crazy but tried it anyways and suddenly all of my mag issues are gone. Not a single double feed and the bolt catch engages every single time in both semi and full auto. Also now when emptying the magazine the bbs fire out at an extremely fast rate. I mean a good 82 bbs in maybe 1 second. The weird thing is that my magazines are clean, I ensured they were all clean prior to taking them to my last game. While it did unfortunately mess with my hop up for a bit, once the oil began to wear away it was fine.

Share this post


Link to post
Share on other sites

T'is strange , my XT panels lock on nice and tight , sounds to me like you have a non-TM RIS unit on it .

i had the same problem. The rail was stock TM. Had to file down a few mms of the rail panels.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.