Jump to content
Gunfighters808

Initial Impressions of the TM SOPMOD M4 AEG

Recommended Posts

Yup, mag screws are only in and nipped up (not even that..).

 

Used a number of different ammo types, including blaster 0.25's. all the same. quite depressing really.

Share this post


Link to post
Share on other sites

Do they still stick if you only partially fill the mags? Also how old are the bb's (strange question I know but had a problem with jams in a tb barrel which was down to old bb's that had swollen slightly). Another suggestion are there any edges on the inside of the mag feed that you can round off?

Share this post


Link to post
Share on other sites

Are you having this issue with 1 mag or multiple mags? Regular or hi-cap?

Buddy of mine had a similar issue a few weeks ago and it was the bbs.

He bought some firefly BBs and they wouldn't feed. Switching to G&G solved the issue.

 

If it is happening in one of a few mags then it might be that mag. If it is happening in all mags then it is probably the BBs.

Share this post


Link to post
Share on other sites

Hi chaps, thanks for the persistence, but I think I've cracked it.

 

I've finally got chance for a buddy of mine to bring his along to a game, so we did a bit of switching about.

 

it appears as though it is a combination of a couple of issues all marrying together.

 

Now, this is with the standard 30/82 round mags (just for those who are interested). The issue was happening with all of my mags (6 in total), to varying degrees, some being worse than others.

 

HIs mags worked fine. Mine were shot.

So we gave mine a real good polish on the inside (as mentioned above), still the same.

Used blasters, still misfeeding, but better.

We swapped his springs out with mine, we had good feeding, all happy, using blasters, but we did have issues using other ammo.

 

 

So it seems as though my springs are getting a little tired, and ammo choice, definitely has to be blasters.

 

 

So, just a bit of a hunt to grab some new springs for the mags and I'll be good to rock.

 

 

So once we had sorted that out, she went back in the case and I used the VSR for the day! Which was lucky, because I was up to my earholes in water, so the AEG might have complained.

Share this post


Link to post
Share on other sites

my SOCOM had problems feeding and it seems like the nozzle was worn...no idea why it happened as I kept it in stock configuration. Didn't touch a single thing on it! Certain rounds wouldn't feed properly on semi. I've never had the upper taken apart from the lower on the socom. Didn't experience this with my sopmod however. I was using KSC .20g perfect. I ruled out the mag because when I finally decided to separate the upper and lower the nozzle had some "chips" so to speak... Still not exactly sure what happened

Share this post


Link to post
Share on other sites

 

So it seems as though my springs are getting a little tired, and ammo choice, definitely has to be blasters.

 

Try stretching out the springs and see if that helps. I had the same issue then cleand out my mags and streteched out the springs and works great now. Still not as good as new, but much better.

Share this post


Link to post
Share on other sites

I just got it.....its a 100% clone with boltcatch.

78ms with 0.28 bb at todays game, and the performance are up to the TM one...really good!

 

The upper has the ordinary thread...so you can use aftermarket parts RIS/RAS without custom work to the thread as you have to do on the TM.

It comes with steelbushings from start.

 

Will do a review in the future

Share this post


Link to post
Share on other sites

Your initial impressions sound good then! I'd be interested also in your thoughts on th build quality of the receiver, stock tube etc and the recoil as I hear the weight is reduced, reducing the recoil!?

look forward to your review!

Share this post


Link to post
Share on other sites

What customisation work did you have to do on the upper receiver threads of your TMs? I've put various different front ends on mine, no issues at all with after-market barrel nuts.

Share this post


Link to post
Share on other sites

What customisation work did you have to do on the upper receiver threads of your TMs? I've put various different front ends on mine, no issues at all with after-market barrel nuts.

Same here. Put a Madbull DD RIS II on mine without any issue.

Share this post


Link to post
Share on other sites

On my first Sopmod I did have to rethread the receiver to get the madbul ris II to fit.

 

The King Arms Larue rail did fit with no problems, and on my actual gun - a Socom - the VFC URX II fitted with no problems.

Share this post


Link to post
Share on other sites

Fitted a Magpul miad grip today and didnt need to mod or shim the plastic base plate. Anyone else found this with the miad? Set screw was removed when fitting base and when fitted was done till it hit the motor plus about 1/8th of a turn.

Share this post


Link to post
Share on other sites

Hey guys, my sopmod is nearly at the point where I'm willing to ###### it off across the forums however I've run into a little snag and I assume others have had this too.

 

Ive just installed the mag adapter and my Genuine Magpul P-mags seem to fit just fine, then I shoot, and they rattle themselves out. It seems as though the mag has a bit too much play from side to side in the magwell.

 

Any way round this, preferably a cheap and easy fix..

 

cheers :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.