Jump to content
Gunfighters808

Initial Impressions of the TM SOPMOD M4 AEG

Recommended Posts

@Hatset i ve heard from others that in most cases the cylinder is not full type, but in mine socom model its a full type cylinder. Anyone knows why and when they change their cylinder pattern or its just random and dont affect anything important.?

 

@mrezzy very nice acquisition sir, but personally i think all those circuits are very expensive and for the price we payed for aour toys they should have included some short of mosfet/circuit.

Edited by VIPER-GR

Share this post


Link to post
Share on other sites

JCheeseright: That was perfect. It was worth the many months of waiting just for that gag.

 

mrezzy: Damn, I'm very jealous. Looking forward to more updates.

 

And…

 

Thats all normal, the issue is your piston head, its tm and non vented which means your o ring will not widen when the piston is released.  Its soley reliant on the o ring being wide enough in the first place… *snip*

 

I'm a bit late but thank you for your help. I'll be ordering from Eagle6 as soon as you get some stock.

Share this post


Link to post
Share on other sites

@Hatset i ve heard from others that in most cases the cylinder is not full type, but in mine socom model its a full type cylinder. Anyone knows why and when they change their cylinder pattern or its just random and dont affect anything important.?

 

@mrezzy very nice acquisition sir, but personally i think all those circuits are very expensive and for the price we payed for aour toys they should have included some short of mosfet/circuit.

 

I'll assume that was a typo...

 

Are you sure it's a full type? There's only one vent hole on it, not two, so if you're looking at the wrong side of the gearbox you'll miss it.

Share this post


Link to post
Share on other sites

Placement of trigger switchaby7uhuv.jpg

 

 

Sent from my iPhone using Tapatalk

Err becareful with the wire routing so you can still fit the frame trigger pin, else you could try and jam it through and muller wirers , just based on pic above.

Share this post


Link to post
Share on other sites

My socom had a non ported cylinder as well... Actually, my 3 previous ones did too as well.

 

My 416, my friends 416 and if I remember correctly, my scar-h all had a ported cylinder.

 

Just an fyi...

 

Guarder Infinite Torque motor doesn't seem to eat up batteries badly.

 

The Guarder pinion gear does NOT mesh properly with the SHS gear set. Guarder pinion gear DOES mesh properly with the stock gear set...and aows for a smoth sounding gun.

 

Using the stock TM pinion gear on the Guarder Infinite Torque Motor results in a very quiet gun when used in conjunction with the SHS gear set.

 

This is all provided that you are using the stock TM pistol grip.

 

The Tienly 30000 torque motor eats up batteries. Those motors allow for up to an m190 spring to be cranked. Very nice trigger response, but eats up batteries. The Tienly pinion gear is very nice. Unfortunately, its on the noisier side for me when used with the SHS gear set. Using the stock TM pinion gear allows for a quiet sounding gun.

 

Tienly motor heats up quicker than the Guarder motor.

 

Between the Guarder and Tienly motors, I prefer the Guarder one personally.

 

Got an OP tomorrow. I'll be doing a lot of shooting then.

 

Sent from my SGH-M919 using Tapatalk

Share this post


Link to post
Share on other sites

Placement of trigger switchaby7uhuv.jpg

 

 

Sent from my iPhone using Tapatalk

So I assume the motor cut-off will be electrical now instead of mechanical, right? Still do you know if there is a chance for a few of these landing in Europe? :)

Edited by Zereck

Share this post


Link to post
Share on other sites

It is all electrical now, from cutoff to selector, to trigger to even the bolt stop. I am having big issues fitting it through the stock now as the wires are way too thick for the stock tube. Sucks, already torn the wire, gotta re-solder.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

And just when you think you've got it all worked out...

 

Reconnected everything, test fire - motor won't turn over. A little bit more investigation shows that it's something to do with the QD battery setup. Putting the battery wires directly onto the contacts on the stock tube and it turns over fine. I need to take another look at the rails, etc. Although already has gold contact bars, so not quite sure what the problem is here...

 

Still, I have.. four hours or so to work it out...

Share this post


Link to post
Share on other sites

DO WANT!! Is that a pre production piece? I need one in my life.

It's actually the prototype model, I've been lucky to get it first. It should be dropping anytime soon now. I'm also having issues with it firing semi as I think my bushing is pushing in too much, making the sector gear cam not mesh with the cut off lever, gonna try to deemed down the bushing...

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Check the fuse hatchet.

 

On my 416 using the shs gears, I get a 2 round burst...or a full auto burst on semi auto when I pull the trigger slowly. It happens maybe once in 75...100 trigger pulls.

 

Generally, that's an indication of a worn cut off lever.

 

My gun isn't that old...probably under 5000 rounds through it.

 

When I stuck the stock gear set back, it never did it again...ever.

 

I have also spread the contacts apart some so as to give the switch more surface area for the cut off lever to trip the switch.

 

Dilemma right now is either to shrug off the burst firing by firing normally (quick trigger pulls and not super slowly pulling it)....or stick the stock gear set back in.

 

 

Any input on the prometheus double torque gear set? Will those slow down the turn over rate of the gears? The local shop has it in stock. Buying it to install is am option as I trust that it's more to the marui spec than the shs is. I also have the wii tech steel cut off lever inbound.

 

Just an FYI, those wii tech hop units are not that great. You will lose quite a bit of velocity...as much as 20-30 fps. You can get back some of it by using Teflon tape around the hop bucking. Also, my friend ended up having the issue of his mags getting kicked out...like the mag catch ends up backing out and unlatches the mag til the mag drops out of the gun.

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

Drilled holes in the end of the contact bars, solder wires in and ditched the fuse assembly/qd part. I was having no luck with it, even without a fuse (wire across the fuse space). I wonder if that little metal bit just can't handle the amps going through it.

 

Anyway, ran all day fine on 7.2v ,2200 15c. Successful test I guess. :)

 

Only thing is... I think I've got a little bored/out of love with it. Or perhaps it's just been one of those days.

Share this post


Link to post
Share on other sites

Check the fuse hatchet.

 

On my 416 using the shs gears, I get a 2 round burst...or a full auto burst on semi auto when I pull the trigger slowly. It happens maybe once in 75...100 trigger pulls.

 

Generally, that's an indication of a worn cut off lever.

 

My gun isn't that old...probably under 5000 rounds through it.

 

When I stuck the stock gear set back, it never did it again...ever.

 

I have also spread the contacts apart some so as to give the switch more surface area for the cut off lever to trip the switch.

 

Dilemma right now is either to shrug off the burst firing by firing normally (quick trigger pulls and not super slowly pulling it)....or stick the stock gear set back in.

 

 

Any input on the prometheus double torque gear set? Will those slow down the turn over rate of the gears? The local shop has it in stock. Buying it to install is am option as I trust that it's more to the marui spec than the shs is. I also have the wii tech steel cut off lever inbound.

 

Just an FYI, those wii tech hop units are not that great. You will lose quite a bit of velocity...as much as 20-30 fps. You can get back some of it by using Teflon tape around the hop bucking. Also, my friend ended up having the issue of his mags getting kicked out...like the mag catch ends up backing out and unlatches the mag til the mag drops out of the gun.

 

 

Sent from my iPad using Tapatalk

everything wii tech is horse poo hence me not stocking it.

 

You've probably just got the balance off when you altered the switch contacts.  When it comes to working on them i tend to leave the contacts and don't move them, from past experience any time i tried to alter them it caused problems, either the issue your describing to much power being sent through before the cut off lifts the trigger blade, or too tight and it catches the trigger blade and it will physically stick even when you release the trigger.  Its a pain in the butt, either replace the contacts with new or just keep playing with them till you get the right position, but i wouldn't keep changing out other tried and tested working part combos.  The shs sets works flawlessly.

 

Adding the promy set is never a bad thing though double the torque ie its easier for your motor to turn the gears but because of the quality of the promy or seigetek sets you will actually see an increase in ROF in most cases or at the very least identical, becuase they are smoother and balanced.   Only downside is the price of the promy gears, but If all promy parts where shs prices, no body would ever buy anything else haha

Edited by Richard Y

Share this post


Link to post
Share on other sites

First time I've ran into this kind of issue with the shs gear set. It will do the burst firing when I set up conditions for it...i.e.....slowly pulling the trigger. By slowly I mean moving it as slow as I can. Even in that condition, it almost rarely happens. But, it happens none the less.

 

Can't be that the contacts fit too tight as I have already spread it apart some. It's more like the cut off lever is not lifting the contacts high enough to disconnect on semi auto. This is the only recoil shock aeg I have had to do this to and I've only used shs gear sets.

 

I'll see if the wii tech cut off lever helps...or just get the prommy double torque gear set anyway.

 

Again, sticking the stock gear set eliminates the burst firing completely.

 

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

What gear set are you using?

I use stock TM gears. I am currently working with BTC airsoft to figure out the semi issue. As we're both stumped.

 

With all three gears in the gearbox, the spectre doesn't not register the cut off switch being pressed by sector gear as it rotates, therefore firing in full auto only.

 

 

My gearbox with the Spectre installed! http://i.imgur.com/IaKMZ2S.jpg

 

 

Also, I had to rewire the entire spectre because the wires are just too thick. Btc used 16 awg wires, way too thick for the sopmod, and it will rip the wire shielding if you try to snake it back underneath the buffer tube upon reassembly. I rewired with 22awg and it is much better space wise. Any suggestions on thinner wire that will be able to handle at least 30amps?

 

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Your gearbox is black...

You sure? It doesn't look black to me. I'd say it was a stock TM gearbox.

 

18awg fits down the buffer tube channels, but you've got to get signal wires down there as well.

With 16awg even front wiring is going to be a tight fit.

 

Speaking of signal wires, how many are there?

Edited by SixtyNiner

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.