Jump to content
-Clover-

WE G39C GBB

Recommended Posts

hmmm, I know what you are saying.

that the hammer is stuck by the sear in the back in auto mode

this wont happen in semi

 

so far so good

 

but I think that the problem still stays even when cocking in semi mode....and shooting afterwards in auto....

so starting in semi and than switching to auto didnt help

(but just to be sure, I will pay attention when I shoot it tomorow and repeat your findings....)

 

but as far as I know, even when cocking in automatic, the hammer wont be catched as long as you dont take the lower receiver apart.

when its dissasembled, and you cock it in automode, than the hammer gets catched indeed

here is what I mean: http://www.youtube.com/watch?v=Izl8IxEQZNU

this is normal since its dissasembled, but when assembled, you dont have that issue (WE even explained how this is in the comments)

WE says the sear is released by the bolt action....

 

 

just to say: it is not a normal way of working that you have to cock in semi and than switch in auto. You should be able to cock in auto as well and shoot without problems too ....

At least it used to work that way with my WE scar

 

I can tell you, if you use that technique to make your gun fire in automode, your gun isnt working properly....

Edited by Riko

Share this post


Link to post
Share on other sites

Oooo...bad boy!! Now can anyone convince PTS to make the airsoft version, if just only the shell and put the WE mag in it?

 

Sorry to hurt everyone's wallets tongue.gif.

I forget if in the catalog they said they were making airsoft G36 Pmags or not...

Share this post


Link to post
Share on other sites

okay, my findings so far concerning my automatic mode problem

 

when shooting semi, its works perfect, it is a real joy to shoot this in semi, the kick is just wow!

 

In auto its a different story, it wont work as good and it depends if you shoot with bursts or not.

If you shoot auto with burst shots, it will happen (at least with my gun) that the sear wont release the hammer dry.gif so I have to switch to semi to release the hammer....

BUT if you shoot the gun from start to finish in full automatic, basically empty your mag, than it will work out. Actually just like on the WE promo film.

So I honestly would like to see them shot the gun with burst, because all they did was empty 18 mags in a row non stop! waggle.gif

 

 

ps: I will upload some pics later on with my laser-red dot on it :)

Edited by Riko

Share this post


Link to post
Share on other sites

How many fps you guys get?

 

edit: I now got nice figures 370 - 390's, so in semi auto it shoots like a dream!

 

 

 

 

 

But I am not happy with the full automatic performance, and I dont really know what can be the problem.

If I start at full auto, so when I enter mag and cock it, than shoot it => I have issues.

If I start at semi auto, than i switch to full auto => I have the same issues.

 

The issue is, either the gun stops firing (hammer is not engaged) or gun stops + all the gas ejects out of the gun!

Now I have no more gas, mainly due to that flamed.gif

 

I dont know why that happens at full auto, but I always find a bb around the valve or feeding area....

Edited by Riko

Share this post


Link to post
Share on other sites

Hi all,

 

I was playing around with my new WE G39C this morning and noticed that even with 0.28g BB's, the hop was going all the way up even at 0 hop setting. I vaguely remember reading this somewhere but can't remember if it's on Arnies or on GGI. Has anyone else experienced this?

 

TIA

Share this post


Link to post
Share on other sites

Maybe the loading nozzle is messed up, causing the bolt at some point to not return to battery?

 

hmmm, how do I know if its really messed up?

 

 

Because when all the gas vents out of the mag in full auto, this is where the jammed bb sits.

full%20auto%20problem.jpg

 

I dunno if that bb causes the venting, but there is always a jammed bb at that spot.

 

When I take it down, I can push the valve forward and it returns back by itself......so it seems to be okay...

 

 

 

 

And just to make sure, but does the nozzle tip looks with everyone like this?

nozzle.jpg

 

its not 100% round (like the top red circle), but at the top its more flat....(like in the bottom red circle)

I think its normal, but I just wanna check :)

 

 

 

 

EDIT:

PROBLEM SOLVED, SOLUTION:

I used another brand of bb's, I used Cybergun AEG Expert bio bb's (.20g)

The bb's that DIDN'T work in full auto were the G&G .20, http://www.wgcshop.com/wgc2008/main/product_detail1.php?search_From=category&item=GG-07-096

So be aware!

 

And I thought those bio bb's of "lesser" quality (I think that because those G&G ones had a very good rep) wouldnt make any difference....BUT NOO :D

I was out of options so, I tought to myself, well why dont I just try the tip from someone on the canada forum and use other bb's!

 

The difference between the G&G and the Cybergun bio other than the fact that its bio, is also that the Cyberguns have much more

Edited by Riko

Share this post


Link to post
Share on other sites

seriously mate, stop spamming all G39 threads with this problem. You have started a thread specifically about this and with time and abit of hope someone may figure out what the problem is.

Share this post


Link to post
Share on other sites

yeah, but everybody views it but nobody answers :)

 

that said..........PROBLEM IS SOLVED biggrin.gif, SOLUTION:

I used another brand of bb's, I used Cybergun AEG Expert bio bb's (.20g)

The bb's that DIDN'T work in full auto were the G&G .20, http://www.wgcshop.com/wgc2008/main/product_detail1.php?search_From=category&item=GG-07-096

So be aware!

 

And I thought those bio bb's of "lesser" quality (I think that because those G&G ones had a very good rep) wouldnt make any difference....BUT NOO :D

I was out of options so, I tought to myself, well why dont I just try the tip from someone on the canada forum and use other bb's!

 

The difference between the G&G and the Cybergun bio other than the fact that its bio, is also that the Cyberguns have much more

Share this post


Link to post
Share on other sites

yeah, but everybody views it but nobody answers :)

 

That's cos maybe not everyone has the WE G39C and those that do may not have that problem & therefore may not know the cause. But I did notice your post 3xposts here and in GGI :D. Though LordElpus does have a point about netiquette & about posting a problem just once.

 

that said..........PROBLEM IS SOLVED biggrin.gif, SOLUTION:

I used another brand of bb's, I used Cybergun AEG Expert bio bb's (.20g)

The bb's that DIDN'T work in full auto were the G&G .20, http://www.wgcshop.com/wgc2008/main/product_detail1.php?search_From=category&item=GG-07-096

So be aware!

 

And I thought those bio bb's of "lesser" quality (I think that because those G&G ones had a very good rep) wouldnt make any difference....BUT NOO :D

I was out of options so, I tought to myself, well why dont I just try the tip from someone on the canada forum and use other bb's!

 

The difference between the G&G and the Cybergun bio other than the fact that its bio, is also that the Cyberguns have much more

Thanks for sharing the result. That's definitely food for thought. If you have any further technical insights as to why, that'll be useful information too. Cheers.

Share this post


Link to post
Share on other sites

EDIT:

PROBLEM SOLVED, SOLUTION:

I used another brand of bb's, I used Cybergun AEG Expert bio bb's (.20g)

The bb's that DIDN'T work in full auto were the G&G .20, http://www.wgcshop.com/wgc2008/main/product_detail1.php?search_From=category&item=GG-07-096

So be aware!

 

And I thought those bio bb's of "lesser" quality (I think that because those G&G ones had a very good rep) wouldnt make any difference....BUT NOO :D

I was out of options so, I tought to myself, well why dont I just try the tip from someone on the canada forum and use other bb's!

The difference between the G&G and the Cybergun bio other than the fact that its bio, is also that the Cyberguns have much more

 

I hear those Canucks really know their airsoft! Good to hear things worked out for you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.