Jump to content
Reppyboyo

GHK G5 First Impressions.

Recommended Posts

Good ole FB - I joined up by searching for "GHK G5 GBB" and FB put the group to the top of the list. That said on more than one occasion FB has refused to find people I am friends with despite putting in their full name!

 

B->

Share this post


Link to post
Share on other sites

So I've decided to sell my G5 to clear the space that it's taking up on my credit card. Great gun, but I prefer playing with my pistols and the wife wants to book a holiday. So it's in the Gas Guns UK Sales thread just now, if anyone's looking for one:

 

http://arniesairsoft.co.uk/forums/index.php?/topic/212225-ghk-g5-gbbr-black-gen-2-5-mags/&do=findComment&comment=2664412

Share this post


Link to post
Share on other sites

Just picked mine up, however I did notice one thing wrong immediately upon disassembly. The hop up bumper seemed to be rotated to the right a bit. i thought maybe the barrel has been rotated. upon closer inspection I noticed my hop up arm, the part that grabs the nub, had an an angle on it. I had to file it down slightly to fix it. Seems to seat better now, but definitely can use some shimming around the arm. has way too much play...

Anyways, has anyone tried fitting the PTS SSG selector onto this? Wondering if it will fit...

Share this post


Link to post
Share on other sites

So i tightened the bottom of the mags (the two big screws) and they stopped leaking from the bottom. Now two of them are leaking from the top.... what gives?! I tried to tighten the valve but that seems tight already.

Share this post


Link to post
Share on other sites

So i tightened the bottom of the mags (the two big screws) and they stopped leaking from the bottom. Now two of them are leaking from the top.... what gives?! I tried to tighten the valve but that seems tight already.

 

Or just soak the o-rings in silicone oil for a day. It'll probably do the trick.

 

 

Fox

Share this post


Link to post
Share on other sites

Speaking of soaking o rings: Meant to post on here a while ago when I still had my G5. I had issues with it not being able to fire on full auto because the nozzle couldn't return fast enough and would be very tight in the bolt. This happened after a strip down and a maintain. After a couple months sitting in a case it begun working absolutely fine again. My guess is I shouldn't have put silicon anywhere near the grey o ring as it seems it had swollen enough to stop proper cycling!

 

Probably a very common sense thing but any newbies out there to maintenance take heed!

Edited by Krydel

Share this post


Link to post
Share on other sites

I found that the grey Oring they use SUCKS, its loose, and soft, and just generally sucks

I put a black Oring from a standard set of Oring replacements, its the same diameter, but a fatter Oring that doesnt jiggle and stretch in the slot like the original, havent had a single issue ever since

Share this post


Link to post
Share on other sites

tried soaking in silicone for a day, no dice. I can see it coming from the inside of the rubber rectangular part that vents the gas (around the BB feed lip area) 

Share this post


Link to post
Share on other sites

tried soaking in silicone for a day, no dice. I can see it coming from the inside of the rubber rectangular part that vents the gas (around the BB feed lip area) 

 

Did you soak the orings individually? There's no way it doesn't work pretty much. But try replacing the o-ring then (and the new one, have it soaked in silicone). Also, make sure the valve is well tight.

Share this post


Link to post
Share on other sites

One of my magazine's had the same problem as Honzo, so I did the same thing - took out soaked the valve o rings for a while. Instead of fixing the problem, when i put everything back together and tightened it back up, all gas that went in through the fill valve came straight out the outlet valve. Bizarre, as thats pretty much the one thing that IS meant to work. Gave it to a tech and he said he couldn't for the life of him get it to hold gas and there was nothing for it but a new valve or a new mag. Ended up just getting a new mag.

 

Odd, because tightening the base screws and siliconing the valves worked fine on the other 5.

  • Like 1

Share this post


Link to post
Share on other sites

Krydel, that's interesting. Yeah, it doesnt seem to be sitting very well (2 out of 5). The remaining three, i tighten the screws on the bottom and the usually fixes the problem. I'll give it another day. 
 

In the meantime,  how are the new GHK stanag metal magazines? I assume they work well in the g5? Might order a couple of those....

Share this post


Link to post
Share on other sites

Guys, has anyone installed the 1J nozzle, or just removed the nozzle from the bolt carrier?

 

I had a pretty ###### day, but I wanted to swap the stock nozzle out, and I couldn't figure how to take it out of the bolt carrier! The guides WON'T.COME.OFF. I don't see a way of removing them. They can't be removed inwards, and they can't be removed outwards, I pulled the ###### out of the nozzle out and just broke everything. That's how ###### I was. And even now, I can't figure it out. The nozzle was pretty hardy, so I used a screwdriver and mangled the bolt carrier a bit too ;) I'm really mad with it. Couldn't find any guides online.

 

EDIT: OK, apparently they are supposed to come from inside out, it just doesn't look like it at all. But found some obscure video that didn't show up at all on it.

 

 

Fox

Edited by Fox62

Share this post


Link to post
Share on other sites

I found them an absolute *badgeress* to prod out, but if you get a really small/thin traditional L-shaped allen key you can get to them to poke out quite easily :)

  • Like 1

Share this post


Link to post
Share on other sites

I found them an absolute *badgeress* to prod out, but if you get a really small/thin traditional L-shaped allen key you can get to them to poke out quite easily :)

 

Yeah, I just got the nozzle installed and the gun's working fine.

 

It's just not a very intuitive design, and it's different on WAs (you actually push the guide in on those), and WEs (they have a little screw and come off). Anyway, I'm more chilled now, I just had to rant somewhere, I hate breaking parts, but I was really mad at that assembly. It also didn't help that I couldn't find any guides online.

 

Thanks!

Share this post


Link to post
Share on other sites

Any issues with not using the gray O-ring? I choronoed with and without that gray O-ring and FPS is still the same.

 

What's the actual function of the gray O-ring?

Share this post


Link to post
Share on other sites

Anyone having issues with jamming?

 

I have this issue where the bolt does not return 100% because of a poor bb load. I happens more frequently when I pull the trigger rapidly on semi. But I also wonder if its because the feed lips are extremely tight, causing the bolt to slow down and misguide the bbs. Either that or I'm scoring the bbs when loading them, which could possibly prevent them from rolling up the feed ramp?

Share this post


Link to post
Share on other sites

i found that I had some double feeds and jams, then I rounded the bottom of the loading finger so it wont catch a second BB and try to remove it from the mag, havent had a problem since

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.