Jump to content

Cut off lever not interacting with trigger contacts


Recommended Posts

Hi Guys, hoping someone can assist with a strange problem I'm having!

 

Working on a DMR with a cut off selector late to keep it in semi. But the cut off lever is not lifting the trigger contact, so stays in full auto.

 

I have tried the following already:

 

Different triggers x 3

Different switch block

different selector plate

different gearset

 

I have videoed it cycling. You can see the sector gear is hitting the cut off lever, but then seems to skip past it, and I cannot for the life of me fgure out whats wrong.

 

None of the parts show any signs of damage.

 

 

Thanks in advance!

Link to post
Share on other sites

Thanks. I have a JG one that doesn’t quite fit in the shell (too small a hole for it to pivot on) but it looks to be the same sizes and this one has no obvious wear. I did buy another one but I seem to have misplaced it in the shed!

Any obvious points I should look at to see it’s worn? Looks spotless to me?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.