Jump to content
Gunfighters808

Initial Impressions of the TM SOPMOD M4 AEG

Recommended Posts

Hey guys, so Ive done a bit of searching in this thread but info is fairly hard to find. Im picking up a SOPMOD used, but am wanting to ditch the crane stock in favor of a CTR stock, meaning I would have to run the battery in the buffer tube, like a buffer tube battery. Is this possible? Im so confused about how the stock QD battery works and how to change it out for standard plugs in the tube. I also know the recoil system is somewhere near the stock tube but dont know exactly where. Im really hesitant to front wire it so if I cant run a battery in the tube I guess Ill have to keep the crane stock on there :/

  • Like 1

Share this post


Link to post
Share on other sites

The others are right - your choices are either front-wiring or keeping the original. I'd honestly keep the original - with some upgrades it's a really neat system, totally invisible (unlike front-wiring) and does help the balance of the gun if you've got a ton of accessories stuck on the front.

Share this post


Link to post
Share on other sites

Just bought a used twice Sopmod this weekend! Should be here Wednesday, I am hoping along with three mags. Will be looking at getting some P Mags for it and enjoying it  :D

Share this post


Link to post
Share on other sites

Awsome set up! I have one very similar! It curently has the 13 inch VTAC rail and a battle axe stock. I'm gonna swap the rail out for the 9 inch soonest! Mines front wired into a PEQ box.

For a rear wired m4 you could try the madbull battle ax it seems tho have good battery space!

Share this post


Link to post
Share on other sites

Awsome set up! I have one very similar! It curently has the 13 inch VTAC rail and a battle axe stock. I'm gonna swap the rail out for the 9 inch soonest! Mines front wired into a PEQ box.

 

Yey me too, but I got the Troy TRX instead... I liked the PEQ setup quite a lot more after I switched, a lot less rear heavy with the recoil weight and batteries all at the back! 

Share this post


Link to post
Share on other sites

Short question: Normally, when you press the boltcatch after an empty magazine, the boltcatch goes back to normal position very easily and "smooth", but what might be the problem if it's not that smooth, you have to press it a little harder and there's a "click" sound when you push it back in?

 

When i got the gun used, that happened in 1 out of 3 situations, but now it happens everytime the bolt-lock engages.

Edited by KyleKatarn

Share this post


Link to post
Share on other sites

Got a new piston, same lock up issue.

Wired the gun directly to deans and lipo

Still will not cycle.

Hooked it up to the motor outside the grip and it spun so something inside the gearbox is locked? I took it apart twice and nothing fixed it.

 

Help?

Share this post


Link to post
Share on other sites

I just received my madbull DD RIS, but after installing the barrel nut the barrel wobbles. I need some washers but unfortunately those from echigoya are out of stock, so can i use washers for a normal aeg? Or is there a trick to eliminate wobble with something else, without buying extra washers?

Edited by KyleKatarn

Share this post


Link to post
Share on other sites

For a rear wired m4 you could try the madbull battle ax it seems tho have good battery space!

 

How would this stock work with the contacts on the stock tube? Has anyone modded a non-TM stock to use with a Sopmod yet? If there was a way that still enables all stock positions to be used, I would be interested.

Share this post


Link to post
Share on other sites

Double check polarity, it that still fails remove the buffer tube to take tension off the spring, remove the pistol grip and use a small screw driver to move the gears and feel for problems.

 

If you've wiped the threads in the lower you can do what another user did, drill through the lower and make dimples in the tube, then tap and screw in set screws 3 is ideal to secure it, then replace with the castle nut with a proper locking ring from laylax.

 

How common is it for people to wreck the threads? I've had mine Fathammers apart dozens of times each and my threads are all still good. Slow down, don't just try and jam it in and turn it, apply pressure to overcome the spring (a bit of lube on the base of the guide helps), then gently turn anti-clockwise until you feel the threads line up, then start turnining in, I generally turn the tube in until it bottoms out and then back it out one full turn, lastly really lean on the castle nut with a well fitting wench to do it up tight.

Share this post


Link to post
Share on other sites

I just received my madbull DD RIS, but after installing the barrel nut the barrel wobbles. I need some washers but unfortunately those from echigoya are out of stock, so can i use washers for a normal aeg? Or is there a trick to eliminate wobble with something else, without buying extra washers?

 

had same with mine, thankfully i got some washers with it, don't know if they are bespoke or what.  I've also used rubber o-rings to tighten it up as well, can leave the barrle in a slightly movable state though :P

Share this post


Link to post
Share on other sites

I've been having issues trying to get the power up on mine. Stock it was as expected (280 ish?) and compression seems good when tested, but I'm not seeing the results expected from the springs in it.

 

I've had an Eagle 90, 100 and 110 in it and currently it's got the 110 (allegedly 380-400) doing 330fps. Sadly I think this is too much spring for a standard gear set (hornbill) as it keeps blowing fuses at a rate of knots. It's using exactly the same setup electircally as it has the last year or more, it's just the spring that's different. Ghetto fuse modded it in the field on Sunday with the driver from a removable screwdriver. This worked fine up til the point smoke started coming out. Fortunately wasn't a lipo fire, I suspect just the "fuse" getting so hot it started melting wiring/solder. Still fires fine though.

 

Obviously I'm going to downgrade the spring again, but I'd certainly like to get nearer to 350 with the 100.

 

Upgrades wise - standard hop/barrel, hornbill gears, prometheus cylinder head/nozzle/gold contact bars/spring guide.

 

Any thoughts?

Share this post


Link to post
Share on other sites

Check how well the gears move with the cylinder assembly out and the gearbox shell clamped down by the screw. I suspect a shim job that needs to be improved.

 

Ive been running my gun with a cut down spring. Currently shoots about 380-90 fps using the stock motor and a 7.4v lipo.

 

Sent from my Samsung Galaxy S4 using Tapatalk 2

 

 

Share this post


Link to post
Share on other sites

Check your shimming if you are blowing fuses, but it sounds like you need more torque, I'd ditch the fuse, upgrade the wiring, and clean the trigger contacts, and if you can drop in a MOSFET, then drop in a Lonex A1 or A2 or modify your EG1000.

 

Modern motors negate the need for Torque gearsets.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use and the use of session cookies.